const regex = /(?<=(?<!@)(?:@@)*)@([^\s@]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=(?<!@)(?:@@)*)@([^\\s@]*)$', 'gm')
const str = `test
@test
@test aux
@test @aux
@test @@aux
@test @@@aux
@test @@@@aux
@test @@@@@aux`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);