using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:https?://(?:[1-3]\.alpha|[45]\.beta)\.com|(?:http://[6-7]\.beta|https://6\.alpha)\.org)";
string input = @"http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
http://4.beta.com
http://5.beta.com
https://4.beta.com
https://5.beta.com
http://6.beta.org
http://7.beta.org
https://6.alpha.org
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}