$re = '@(?:https?://(?:[1-3]\.alpha|[45]\.beta)\.com|(?:http://[6-7]\.beta|https://6\.alpha)\.org)@m';
$str = 'http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
http://4.beta.com
http://5.beta.com
https://4.beta.com
https://5.beta.com
http://6.beta.org
http://7.beta.org
https://6.alpha.org
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);