const regex = new RegExp('(?:https?://(?:[1-3]\\.alpha|[45]\\.beta)\\.com|(?:http://[6-7]\\.beta|https://6\\.alpha)\\.org)', 'gm')
const str = `http://1.alpha.com
http://2.alpha.com
http://3.alpha.com
https://1.alpha.com
https://2.alpha.com
https://3.alpha.com
http://4.beta.com
http://5.beta.com
https://4.beta.com
https://5.beta.com
http://6.beta.org
http://7.beta.org
https://6.alpha.org
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}