using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @";([^;]+)$";
string input = @"Car;House;I have a car in my house
Mobile;Phone;She has a mobile phone";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}