$re = '/;([^;]+)$/m';
$str = 'Car;House;I have a car in my house
Mobile;Phone;She has a mobile phone';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);