package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m);([^;]+)$`)
var str = `Car;House;I have a car in my house
Mobile;Phone;She has a mobile phone`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}