$re = '/^(?=[a-zA-Z0-9]{10,})(?=.*\d)(?=.*[A-Z].*[a-z]).+$/m';
$str = 'bAse730onE
QwErTy911poqqqq
asasasasasasasaas
QWERTYqwerty
123456123456
..........
A1213pokl';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);