re = /^(?=[a-zA-Z0-9]{10,})(?=.*\d)(?=.*[A-Z].*[a-z]).+$/m
str = 'bAse730onE
QwErTy911poqqqq
asasasasasasasaas
QWERTYqwerty
123456123456
..........
A1213pokl'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end