import re
regex = re.compile(r"^(?=[a-zA-Z0-9]{10,})(?=.*\d)(?=.*[A-Z].*[a-z]).+$", flags=re.MULTILINE)
test_str = ("bAse730onE\n"
"QwErTy911poqqqq\n\n"
"asasasasasasasaas\n"
"QWERTYqwerty\n"
"123456123456\n"
"..........\n"
"A1213pokl")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")