package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)@(\w+)`)
var str = `[quote]
@lalalala
Lorem ipsum dolor sit amet, consectetur adipiscing elit. Cras viverra ornare lectus sit amet dignissim. Vestibulum a mi leo. Nunc placerat accumsan elit, nec luctus ante malesuada sed. Quisque at urna non erat suscipit pharetra.
[/quote]
Morbi massa mauris, consequat vitae sem eu, maximus posuere ligula. Fusce pretium ultricies lectus sit amet bibendum. Aliquam nec dolor urna.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}