import re
regex = re.compile(r"(?i)\n?-* ?(?:BEGIN|END) (?:(?:PRIVATE|PUBLIC)(?: RSA)?|RSA (?:PRIVATE|PUBLIC)) KEY ?-*\n?", flags=re.MULTILINE)
test_str = ("-----BEGIN RSA PUBLIC KEY-----\n"
"0123456789\n"
"0123456789\n"
"abcdefgh\n"
"-----END RSA PUBLIC KEY-----")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")