re = /(?i)\n?-* ?(?:BEGIN|END) (?:(?:PRIVATE|PUBLIC)(?: RSA)?|RSA (?:PRIVATE|PUBLIC)) KEY ?-*\n?/m
str = '-----BEGIN RSA PUBLIC KEY-----
0123456789
0123456789
abcdefgh
-----END RSA PUBLIC KEY-----'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end