using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ix)(?>[^\S ]\s*|\s{2,})(?=(?:(?:[^<]++|<(?!\/?(?:textarea|pre)\b))*+)(?:<(?>textarea|pre)\b|\z))";
string input = @"<body>
<section id=""fd-container"" class=""bgFFF celupSection"">
<div class=""container"">
<div class=""row"">
<div id=""primary"" class=""col-md-9 content-area"">
<main id=""main"" role=""main"">
<div class=""table-info""><span class=""info"">테이블번호: 13</span></div>
<article id=""post-445"" class=""post-content post-445 company type-company status-publish has-post-thumbnail hentry category-32 wpautop"">
<header class=""entry-header""><span class=""screen-reader-text"">할머니잔치국수</span>
<h1 class=""entry-title"">할머니잔치국수</h1>
</header>
<div class=""entry-content"">
<div class=""vc_row wpb_row vc_row-fluid"">
<div class=""wpb_column vc_column_container vc_col-sm-12"">
<div class=""vc_column-inner"">
<div class=""wpb_wrapper"">
<div class=""wpb_text_column wpb_content_element"">
<div class=""wpb_wrapper"">
<div class=""fd-foodDetailProBox style1"">
<ul class=""fd-foodDetailProList"">
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-01-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">비빔국수</div>
<div class=""fd-foodProLeftContent"">최상의 마법 비빔국수</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 313kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">4,900</div>
</div>
</li>
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-02-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">잔치국수</div>
<div class=""fd-foodProLeftContent"">할머니의 정성이 잔득 담긴 잔치국수</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 280kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">4,900</div>
</div>
</li>
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-03-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">콩국수</div>
<div class=""fd-foodProLeftContent"">직접 빚어 만든 콩국수</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 354kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">5,900</div>
</div>
</li>
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-05-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">도토리묵</div>
<div class=""fd-foodProLeftContent"">깻잎과 도토리묵 환상 컴비네이션</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 423kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">8,900</div>
</div>
</li>
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-04-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">물만두</div>
<div class=""fd-foodProLeftContent"">한입에 속 식감이 살아 있는 물만두</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 154kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">6,900</div>
</div>
</li>
<li class=""fd-foodDetailPro fd-flex"">
<div class=""fd-foodDetailProLeft fd-flex"">
<div class=""fd-foodProLeftTitleBox"">
<div class=""fd-foodProImg""><img width=""66"" height=""66"" src=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg"" alt="" srcset=""http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-100x100.jpg 100w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-150x150.jpg 150w, http://webpos.wper.kr/wp-content/uploads/2018/09/1000-06-60x60.jpg 60w"" sizes=""(max-width: 66px) 100vw, 66px"" class=""attachment-66x66 size-66x66"" /></div>
</div>
<div class=""fd-foodProLeftContentBox"">
<div class=""fd-foodProSubTitle"">파전</div>
<div class=""fd-foodProLeftContent"">군침이 감도는 해물파전</div>
<div class=""fd-foodProLeftContent"">영양정보 칼로리 654kcal</div>
</div>
</div>
<div class=""fd-foodDetailProRight fd-flex fd-align-center fd-justy-center"">
<div class=""fd-foodDetailProPrice"">13,900</div>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</article>
</main>
</div>
</div>
</div>
</section>
</body>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}