#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=SJ顺丰\s)\d+"
Local $sString = "<div>" & @CRLF & _
" <table style="border: 1px solid #ECECEC; height: 125px; padding-left: 5px; padding-right: 5px; background-color: #EEF7FF; width: 100%">" & @CRLF & _
" <tr>" & @CRLF & _
" <td style="font-size: 20px; font-weight: bold; width: 252px; padding-top: 20px;">关注信公众号</td>" & @CRLF & _
" <td></td>" & @CRLF & _
" <td rowspan="2">" & @CRLF & _
" <img style="margin-top: 8px;" src="../Resources/Images/Box/qrcode_for_gh.png" /></td>" & @CRLF & _
" </tr>" & @CRLF & _
" <tr>" & @CRLF & _
" <td style="font-size: 14px; vertical-align: top;">您可以随时接收物流动态、为包裹付款、获取最新的活动信息。</td>" & @CRLF & _
" <td style="font-size: 14px; width: 260px; vertical-align: top;"><span style="font-size: 14px; float: right;">以最方便的方式玩转海淘></span><br />" & @CRLF & _
" <span style="font-size: 14px; float: right;">扫一扫,关注</span></td>" & @CRLF & _
" </tr>" & @CRLF & _
" </table>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<br />" & @CRLF & _
"<div class="main">" & @CRLF & _
" <input type="hidden" id="boxcount" value="1" />" & @CRLF & _
" " & @CRLF & _
" <input id="tab1" type="radio" name="tabs" style="display: none;" checked="checked"" & @CRLF & _
" />" & @CRLF & _
" <label for="tab1"><a style="cursor: pointer;">XJ202002232539531</a></label>" & @CRLF & _
" " & @CRLF & _
" <section id="content1">" & @CRLF & _
" <p class="tc mt20"></p>" & @CRLF & _
" <div class="result-top"><span class="col1">时间</span><span class="col2">地点和跟踪进度</span></div>" & @CRLF & _
" <table class="result-info2" cellspacing="0">" & @CRLF & _
" <tbody>" & @CRLF & _
" " & @CRLF & _
" <tr class="last">" & @CRLF & _
" <td class="row1">2020/3/8 10:12:11</td>" & @CRLF & _
" <td class="status status-first"> </td>" & @CRLF & _
" <td>已发货:(SJ顺丰 051131145456) <a target = "_blank" href="http://www.kuaidi100.com/chaxun?com=shunfeng&nu=051131145456" style="text-decoration:none;" onclick="AddQuery()">国内物流查询>></a></td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="row1">2020/3/8 10:11:11</td>" & @CRLF & _
" <td class="status"> </td>" & @CRLF & _
" <td>已清关 </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="row1">2020/3/5 13:58:00</td>" & @CRLF & _
" <td class="status"> </td>" & @CRLF & _
" <td>已到达清关口岸 </td>" & @CRLF & _
" </tr>" & @CRLF & _
" `"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")