import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=SJ顺丰\\s)\\d+";
final String string = "<div>\n"
+ " <table style=\"border: 1px solid #ECECEC; height: 125px; padding-left: 5px; padding-right: 5px; background-color: #EEF7FF; width: 100%\">\n"
+ " <tr>\n"
+ " <td style=\"font-size: 20px; font-weight: bold; width: 252px; padding-top: 20px;\">关注信公众号</td>\n"
+ " <td></td>\n"
+ " <td rowspan=\"2\">\n"
+ " <img style=\"margin-top: 8px;\" src=\"../Resources/Images/Box/qrcode_for_gh.png\" /></td>\n"
+ " </tr>\n"
+ " <tr>\n"
+ " <td style=\"font-size: 14px; vertical-align: top;\">您可以随时接收物流动态、为包裹付款、获取最新的活动信息。</td>\n"
+ " <td style=\"font-size: 14px; width: 260px; vertical-align: top;\"><span style=\"font-size: 14px; float: right;\">以最方便的方式玩转海淘></span><br />\n"
+ " <span style=\"font-size: 14px; float: right;\">扫一扫,关注</span></td>\n"
+ " </tr>\n"
+ " </table>\n"
+ "</div>\n\n"
+ "<br />\n"
+ "<div class=\"main\">\n"
+ " <input type=\"hidden\" id=\"boxcount\" value=\"1\" />\n"
+ " \n"
+ " <input id=\"tab1\" type=\"radio\" name=\"tabs\" style=\"display: none;\" checked=\"checked\"\n"
+ " />\n"
+ " <label for=\"tab1\"><a style=\"cursor: pointer;\">XJ202002232539531</a></label>\n"
+ " \n"
+ " <section id=\"content1\">\n"
+ " <p class=\"tc mt20\"></p>\n"
+ " <div class=\"result-top\"><span class=\"col1\">时间</span><span class=\"col2\">地点和跟踪进度</span></div>\n"
+ " <table class=\"result-info2\" cellspacing=\"0\">\n"
+ " <tbody>\n"
+ " \n"
+ " <tr class=\"last\">\n"
+ " <td class=\"row1\">2020/3/8 10:12:11</td>\n"
+ " <td class=\"status status-first\"> </td>\n"
+ " <td>已发货:(SJ顺丰 051131145456) <a target = \"_blank\" href=\"http://www.kuaidi100.com/chaxun?com=shunfeng&nu=051131145456\" style=\"text-decoration:none;\" onclick=\"AddQuery()\">国内物流查询>></a></td>\n"
+ " </tr>\n"
+ " \n"
+ " <tr>\n"
+ " <td class=\"row1\">2020/3/8 10:11:11</td>\n"
+ " <td class=\"status\"> </td>\n"
+ " <td>已清关 </td>\n"
+ " </tr>\n"
+ " \n"
+ " <tr>\n"
+ " <td class=\"row1\">2020/3/5 13:58:00</td>\n"
+ " <td class=\"status\"> </td>\n"
+ " <td>已到达清关口岸 </td>\n"
+ " </tr>\n"
+ " `";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}