using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=SJ顺丰\s)\d+";
string input = @"<div>
<table style=""border: 1px solid #ECECEC; height: 125px; padding-left: 5px; padding-right: 5px; background-color: #EEF7FF; width: 100%"">
<tr>
<td style=""font-size: 20px; font-weight: bold; width: 252px; padding-top: 20px;"">关注信公众号</td>
<td></td>
<td rowspan=""2"">
<img style=""margin-top: 8px;"" src=""../Resources/Images/Box/qrcode_for_gh.png"" /></td>
</tr>
<tr>
<td style=""font-size: 14px; vertical-align: top;"">您可以随时接收物流动态、为包裹付款、获取最新的活动信息。</td>
<td style=""font-size: 14px; width: 260px; vertical-align: top;""><span style=""font-size: 14px; float: right;"">以最方便的方式玩转海淘></span><br />
<span style=""font-size: 14px; float: right;"">扫一扫,关注</span></td>
</tr>
</table>
</div>
<br />
<div class=""main"">
<input type=""hidden"" id=""boxcount"" value=""1"" />
<input id=""tab1"" type=""radio"" name=""tabs"" style=""display: none;"" checked=""checked""
/>
<label for=""tab1""><a style=""cursor: pointer;"">XJ202002232539531</a></label>
<section id=""content1"">
<p class=""tc mt20""></p>
<div class=""result-top""><span class=""col1"">时间</span><span class=""col2"">地点和跟踪进度</span></div>
<table class=""result-info2"" cellspacing=""0"">
<tbody>
<tr class=""last"">
<td class=""row1"">2020/3/8 10:12:11</td>
<td class=""status status-first""> </td>
<td>已发货:(SJ顺丰 051131145456) <a target = ""_blank"" href=""http://www.kuaidi100.com/chaxun?com=shunfeng&nu=051131145456"" style=""text-decoration:none;"" onclick=""AddQuery()"">国内物流查询>></a></td>
</tr>
<tr>
<td class=""row1"">2020/3/8 10:11:11</td>
<td class=""status""> </td>
<td>已清关 </td>
</tr>
<tr>
<td class=""row1"">2020/3/5 13:58:00</td>
<td class=""status""> </td>
<td>已到达清关口岸 </td>
</tr>
`";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}