using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\b(?:mr|mrs|ms|miss|messrs|mmes|dr|prof|rev|sr|jr|and)\b|&)\.?";
string input = @"one and two and three & four";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}