re = /(?:\b(?:mr|mrs|ms|miss|messrs|mmes|dr|prof|rev|sr|jr|and)\b|&)\.?/m
str = 'one and two and three & four'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end