$re = '/(?:\b(?:mr|mrs|ms|miss|messrs|mmes|dr|prof|rev|sr|jr|and)\b|&)\.?/m';
$str = 'one and two and three & four';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);