#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$"
Local $sString = " ‘Dabes Zarger Gackett" & @CRLF & _
" Manes Hackett` Barger" & @CRLF & _
" Modil Gobam ‘Nomes" & @CRLF & _
" Jarrett Bar,ger Hackett, " & @CRLF & _
" LuIs T’rivino" & @CRLF & _
" LuIs Triv,ino " & @CRLF & _
" Roofer ‘doores " & @CRLF & _
" Steven JR Morr's" & @CRLF & _
" Pakkir Ab’dul Kalam" & @CRLF & _
" Ku,mar" & @CRLF & _
" Pakkir A–bdul Kalam" & @CRLF & _
" Pakkir Ab–dul Kalam" & @CRLF & _
" Ar-t-hur" & @CRLF & _
" M " & @CRLF & _
" m" & @CRLF & _
" sp" & @CRLF & _
" Mayank S-hankar" & @CRLF & _
" mayank " & @CRLF & _
" shankar" & @CRLF & _
" jainuddin ad" & @CRLF & _
" jainuddin a" & @CRLF & _
" abd-ul" & @CRLF & _
" Pakkir A'bdul Kalam" & @CRLF & _
" Pakkir Ab’dul Kalam" & @CRLF & _
" Pakkir Ab'dul Kalam" & @CRLF & _
" Pakkir Ab`dul Kalam" & @CRLF & _
" Kumar A" & @CRLF & _
" A kumar" & @CRLF & _
" Ku,mar" & @CRLF & _
" Pakkir A-bdul Kalam" & @CRLF & _
" Pakkir Ab-dul Kalam" & @CRLF & _
" Pakkir A–bdul Kalam" & @CRLF & _
" Pakkir Ab–dul Kalam" & @CRLF & _
" Pakkir Abdul Kalam"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")