// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\s+)?(((([a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?(((\s+[a-zA-Z]+)|(\s+[a-zA-Z][a-zA-Z\-\–\`\'\’]+[a-zA-Z]+)))?)|([a-zA-Z ]+))(\s+)?$").unwrap();
let string = " ‘Dabes Zarger Gackett
Manes Hackett` Barger
Modil Gobam ‘Nomes
Jarrett Bar,ger Hackett,
LuIs T’rivino
LuIs Triv,ino
Roofer ‘doores
Steven JR Morr's
Pakkir Ab’dul Kalam
Ku,mar
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Ar-t-hur
M
m
sp
Mayank S-hankar
mayank
shankar
jainuddin ad
jainuddin a
abd-ul
Pakkir A'bdul Kalam
Pakkir Ab’dul Kalam
Pakkir Ab'dul Kalam
Pakkir Ab`dul Kalam
Kumar A
A kumar
Ku,mar
Pakkir A-bdul Kalam
Pakkir Ab-dul Kalam
Pakkir A–bdul Kalam
Pakkir Ab–dul Kalam
Pakkir Abdul Kalam";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}