#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:https?:\/\/)(?:www\.)?)?test\.com(?:(?:(?:\/)?(?:\/subfolder\/?)?(?:\/\?\S+\/?)?)?(?:\?\S+)?)?(?:\/)?$"
Local $sString = "test.com" & @CRLF & _
"https://test.com" & @CRLF & _
"https://test.com?foo=bar" & @CRLF & _
"https://test.com/" & @CRLF & _
"https://test.com/?foo=bar" & @CRLF & _
"https://www.test.com" & @CRLF & _
"https://www.test.com/subfolder" & @CRLF & _
"https://www.test.com/subfolder/" & @CRLF & _
"https://www.test.com/subfolder/?foo=bar" & @CRLF & _
"test.com/subfolder" & @CRLF & _
"https://www.test.com/foo" & @CRLF & _
"test.com/foo" & @CRLF & _
"https://www.test.com/jason" & @CRLF & _
"https://www.test.com/jason?foo=bar"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")