package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:https?:\/\/)(?:www\.)?)?test\.com(?:(?:(?:\/)?(?:\/subfolder\/?)?(?:\/\?\S+\/?)?)?(?:\?\S+)?)?(?:\/)?$`)
var str = `test.com
https://test.com
https://test.com?foo=bar
https://test.com/
https://test.com/?foo=bar
https://www.test.com
https://www.test.com/subfolder
https://www.test.com/subfolder/
https://www.test.com/subfolder/?foo=bar
test.com/subfolder
https://www.test.com/foo
test.com/foo
https://www.test.com/jason
https://www.test.com/jason?foo=bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}