import Foundation
let pattern = #"^(?:(?:https?:\/\/)(?:www\.)?)?test\.com(?:(?:(?:\/)?(?:\/subfolder\/?)?(?:\/\?\S+\/?)?)?(?:\?\S+)?)?(?:\/)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
test.com
https://test.com
https://test.com?foo=bar
https://test.com/
https://test.com/?foo=bar
https://www.test.com
https://www.test.com/subfolder
https://www.test.com/subfolder/
https://www.test.com/subfolder/?foo=bar
test.com/subfolder
https://www.test.com/foo
test.com/foo
https://www.test.com/jason
https://www.test.com/jason?foo=bar
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)