re = /((notify|score)(Customer|PaymentArrangement|Product|Rejection|IntPayment|PassReset|TravelMoney)\.(access.log))$/
str = 'notifyProduct.access.log'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end