# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:Nameservers[^\n]*\n.*?)*(?>Hostname:\s+([\S]+)\n)/### push(@nameservers, $1); <-- it works :)\n/gs;t' <<< "
Domain: myDomain.int
DNS: myDomain.int
Registered: 2013-05-17
Expires: 2023-05-31
Registration period: 1 year
VID: no
DNSSEC: Unsigned delegation, DNSSEC disabled, no records
Status: Active
Registrant
Handle: ***N/A***
Name: myName Corp
Attention: Reggie Person
Address: SomeStreet 17
Postalcode: numericZip
City: myCity
Country: XX
Phone: +12 34 56 78 90
Nameservers
Hostname: ns1.dom.ext
Hostname: ns2.dom.ext
Hostname: ns3.dom.ext
"