using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:Nameservers[^\n]*\n.*?)*(?>Hostname:\s+([\S]+)\n)";
string substitution = @"### push(@nameservers, $1); <-- it works :)\n";
string input = @"
Domain: myDomain.int
DNS: myDomain.int
Registered: 2013-05-17
Expires: 2023-05-31
Registration period: 1 year
VID: no
DNSSEC: Unsigned delegation, DNSSEC disabled, no records
Status: Active
Registrant
Handle: ***N/A***
Name: myName Corp
Attention: Reggie Person
Address: SomeStreet 17
Postalcode: numericZip
City: myCity
Country: XX
Phone: +12 34 56 78 90
Nameservers
Hostname: ns1.dom.ext
Hostname: ns2.dom.ext
Hostname: ns3.dom.ext
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}