package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w:\\\w+\\\w+\\\w+\\\w+(?<filename>.*)`)
var str = `C:\a\b\c\abc\xyz\abc.h.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}