re = /^\w:\\\w+\\\w+\\\w+\\\w+(?<filename>.*)/m
str = 'C:\\a\\b\\c\\abc\\xyz\\abc.h.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end