$re = '/^\w:\\\\\w+\\\\\w+\\\\\w+\\\\\w+(?<filename>.*)/m';
$str = 'C:\\a\\b\\c\\abc\\xyz\\abc.h.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);