#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([A-Z]\.)|([A-Za-z]+)|:.*"
Local $sString = ""A. Author, B. Author, C.D. Author (1999): Asdfxyz, 1(2), 3-4."" & @CRLF & _
"" & @CRLF & _
""Author, A., Author, B., Author C.D. (1999): Asdfxyz, 1(2), 3-4.""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")