$re = '/([A-Z]\.)|([A-Za-z]+)|:.*/';
$str = '"A. Author, B. Author, C.D. Author (1999): Asdfxyz, 1(2), 3-4."
"Author, A., Author, B., Author C.D. (1999): Asdfxyz, 1(2), 3-4."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);