import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z]\\.)|([A-Za-z]+)|:.*";
final String string = "\"A. Author, B. Author, C.D. Author (1999): Asdfxyz, 1(2), 3-4.\"\n\n"
+ "\"Author, A., Author, B., Author C.D. (1999): Asdfxyz, 1(2), 3-4.\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}