using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"no_reply:[^:]+:incomplete";
string input = @"opencase_2,initial_state:inquiry,inquiry:no_reply:initial_state:incomplete::,inquiry:reask:secondary_state:complete::";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}