package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)no_reply:[^:]+:incomplete`)
var str = `opencase_2,initial_state:inquiry,inquiry:no_reply:initial_state:incomplete::,inquiry:reask:secondary_state:complete::`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}