re = /no_reply:[^:]+:incomplete/m
str = 'opencase_2,initial_state:inquiry,inquiry:no_reply:initial_state:incomplete::,inquiry:reask:secondary_state:complete::'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end