using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!~)~~(?!~)(.*?)(?=~(?<!~.)~(?!~))";
string input = @"~~333~~
~~this is ~~~~~ a test ~~ test~~
~~~333~~~
~~~~333~~~~
~~~this is ~ a test ~~ test~~test~~
~~this is ~ a test ~~~~
~~333~~ ~~ ~~this is ~ a test ~~~~ ~~this is ~~~~~ a test ~~ test~~ ~~this is ~ a test ~~~~";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}