$re = '/(?<!~)~~(?!~)(.*?)(?=~(?<!~.)~(?!~))/m';
$str = '~~333~~
~~this is ~~~~~ a test ~~ test~~
~~~333~~~
~~~~333~~~~
~~~this is ~ a test ~~ test~~test~~
~~this is ~ a test ~~~~
~~333~~ ~~ ~~this is ~ a test ~~~~ ~~this is ~~~~~ a test ~~ test~~ ~~this is ~ a test ~~~~';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);