import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!~)~~(?!~)(.*?)(?=~(?<!~.)~(?!~))";
final String string = "~~333~~\n"
+ "~~this is ~~~~~ a test ~~ test~~\n\n"
+ "~~~333~~~\n"
+ "~~~~333~~~~\n"
+ "~~~this is ~ a test ~~ test~~test~~\n"
+ "~~this is ~ a test ~~~~\n\n"
+ "~~333~~ ~~ ~~this is ~ a test ~~~~ ~~this is ~~~~~ a test ~~ test~~ ~~this is ~ a test ~~~~";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}