using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=TODAY)(?!\S*?([YMD])(?:(?!\1).\S)*\1)(?:[-+]\d{1,3}[YMD]){1,3}(?=\s|$)";
string input = @"TODAY-1M+12M";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}