import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=TODAY)(?!\\S*?([YMD])(?:(?!\\1).\\S)*\\1)(?:[-+]\\d{1,3}[YMD]){1,3}(?=\\s|$)";
final String string = "TODAY-1M+12M";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}