#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:[0-9a-z]-?){32}\b"
Local $sString = "d3bd55bf-062f-473b-9417-935f62c4c98a" & @CRLF & _
"d3bd55bf062f473b9417935f62c4c98a" & @CRLF & _
"d3bd-55bf062f473b9417935f62c4c98a" & @CRLF & _
"d3bd55-bf06-2f473b9417-935f62c4c98a"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")