package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:[0-9a-z]-?){32}\b`)
var str = `d3bd55bf-062f-473b-9417-935f62c4c98a
d3bd55bf062f473b9417935f62c4c98a
d3bd-55bf062f473b9417935f62c4c98a
d3bd55-bf06-2f473b9417-935f62c4c98a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}