$re = '/\b(?:[0-9a-z]-?){32}\b/m';
$str = 'd3bd55bf-062f-473b-9417-935f62c4c98a
d3bd55bf062f473b9417935f62c4c98a
d3bd-55bf062f473b9417935f62c4c98a
d3bd55-bf06-2f473b9417-935f62c4c98a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);