import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(([A-Za-z]{3,9}:(?:\\/\\/)|www\\.)[A-Za-z0-9.-]+((?:\\/[-\\+~%\\/.\\w_]*)?\\??(?:[-\\+=&;%@.\\w_]*)#?(?:[.\\!\\/\\\\w]*))?)";
final String string = "www.google.com\n"
+ "http://www.google.com\n"
+ "mailto:somebody@google.com\n"
+ "somebody@google.com\n"
+ "www.url-with-querystring.com/?url=has-querystring\n"
+ "my text etc.:https://mywebsite.com/?query=abc0123484R4jFLE !";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}