import re
regex = re.compile(r"(([A-Za-z]{3,9}:(?:\/\/)|www\.)[A-Za-z0-9.-]+((?:\/[-\+~%\/.\w_]*)?\??(?:[-\+=&;%@.\w_]*)#?(?:[.\!\/\\w]*))?)", flags=re.IGNORECASE)
test_str = ("www.google.com\n"
"http://www.google.com\n"
"mailto:somebody@google.com\n"
"somebody@google.com\n"
"www.url-with-querystring.com/?url=has-querystring\n"
"my text etc.:https://mywebsite.com/?query=abc0123484R4jFLE !")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")