using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^([a-z0-9]+(?>-[a-z0-9]+)*?)(?:-([0-9]{4})+)?$(?<![0-9]{2}(?<!20)..)";
string input = @"car-audi-tt-2
car-audi-tt-2-2019
car-audi-tt-2-1919
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}