re = /(?i)^([a-z0-9]+(?>-[a-z0-9]+)*?)(?:-([0-9]{4})+)?$(?<![0-9]{2}(?<!20)..)/m
str = 'car-audi-tt-2
car-audi-tt-2-2019
car-audi-tt-2-1919
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end