#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:"|\G(?<!")(?!\A))(?<r>[^a"\\]*+(?>\\.[^a"\\]*)*+)\K(a|"(*SKIP)(*F))(?(?=((?&r)"))\3)"
Local $sString = "Problem: I have thousands of documents which contains a specific character I don't want. E.g. "the character a". These documents contain a variety of characters, but the a's I want to replace "are inside double quotes or" single quotes." & @CRLF & _
"" & @CRLF & _
"I would "like to find and replace them", and I thought using Regex would be needed. I am using VSCode, but I'm open to any suggestions." & @CRLF & _
"" & @CRLF & _
"My attempt: I was able to find the following regex to match for a specific string containing the "values inside the" ()." & @CRLF & _
"" & @CRLF & _
"".*?(r).*?"" & @CRLF & _
"However, this only highlights the entire quote. I want to highlight the character only." & @CRLF & _
"" & @CRLF & _
"Any solution, "perhaps outside of regex", is welcome."
Local $sSubst = "***\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)